Hi Guys,
I hope this basic AIX commands will help you work with sap.
ls -l -> listing directory & files
chmod -> Changing the directory or file permission(rwx)
chown -> changing the directory or file ownership
mkdir -> create directory
rmdir -> remove directory
touch -> create file
rm -> remove file
Note: use man page for more details about each command {man}
***************************************
ps -> Managing the process ( ps -ef | grep -i)
kill -> terminate the process (kill -9)
******************************************************
To Display if the hardware is 32bit or 64bit
bootinfo -y
To see if you're running with a 32 bit or 64 bit kernel,
bootinfo -k
To identify the memory size:
lsattr -El sys0 -a realmem
To Display number of processor on system:
lscfg | grep proc
Displays the system name, nodename, version, machine ID.
uname -a
version, release, and maintenance level of AIX is running on my system
oselvel -r
To get ipaddress of my machine
ifconfig -a
*****************************************
Working with services:
lssrc -a
refresh
startsrc
stopsrc
*****************************************
Basic Logical volume command:
lsvg --> list volume group
lsvg--> Detail report of particule VG
lsvg -l--> list logical volume(lv) for particular vg
lslv--> Detail report of lv
lsvg -p--> Display the hardisk included in particular vg
lspv --> List all the physical disk
chfs -a size=+1G--> increase the file system
Cluster Basic :
Determine the cluster name and networks
/usr/es/sbin/cluster/utilities/cltopinfo
Cluster Service status
/usr/es/sbin/cluster/utilities/clshowsrv -v
/usr/es/sbin/cluster/utilities/cldump
To identify the volume group which comes under cluster
1.) smitty hacmp
2.) logical volume managment
3.) shared vg
4.) list shared vg
I hope this basic AIX commands will help you work with sap.
ls -l -> listing directory & files
chmod -> Changing the directory or file permission(rwx)
chown -> changing the directory or file ownership
mkdir -> create directory
rmdir -> remove directory
touch -> create file
rm -> remove file
Note: use man page for more details about each command {man
***************************************
ps -> Managing the process ( ps -ef | grep -i
kill -> terminate the process (kill -9
******************************************************
To Display if the hardware is 32bit or 64bit
bootinfo -y
To see if you're running with a 32 bit or 64 bit kernel,
bootinfo -k
To identify the memory size:
lsattr -El sys0 -a realmem
To Display number of processor on system:
lscfg | grep proc
Displays the system name, nodename, version, machine ID.
uname -a
version, release, and maintenance level of AIX is running on my system
oselvel -r
To get ipaddress of my machine
ifconfig -a
*****************************************
Working with services:
lssrc -a
refresh
startsrc
stopsrc
*****************************************
Basic Logical volume command:
lsvg --> list volume group
lsvg
lsvg -l
lslv
lsvg -p
lspv --> List all the physical disk
chfs -a size=+1G
Cluster Basic :
Determine the cluster name and networks
/usr/es/sbin/cluster/utilities/cltopinfo
Cluster Service status
/usr/es/sbin/cluster/utilities/clshowsrv -v
/usr/es/sbin/cluster/utilities/cldump
To identify the volume group which comes under cluster
1.) smitty hacmp
2.) logical volume managment
3.) shared vg
4.) list shared vg